Cette question a été résolue

Can't receive MMS for the life of me

Using Samsing Galaxy S9+. Galaxy is Updated to the current firmware as of Nov 27, 2018, Build R16NW.G965WVLS3ARJ6
.

APN is all set. Used the network provided APN that came only once when I popped in the SIM card, used the one provided on https://fizz.ca/en/faq/what-are-fizz-network-settings-apn what other people used on RFD and reddit with no go.
.
Fizz APN settings are:
.
APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl <===tried without supl
.
If your phone offers you a predetermined APN type, choose “Internet + MMS” <===Samsung S9+
.
Tried other phones as well, Nexus 5 with Lineage OS 14.1 Nov 26, 2018 , Nexus 6p on the latest firmware from Google, Pixel 2 on the latest firmware from Google. All phone can receive MMS but they can not send MMS.
.
Resending the network parameters, waiting 3 minutes and rebooting does nothing for all phones.

John
John

John

User level
Niveau
0
93 / 100
points
Charles
Charles

Charles

User level
Niveau
1
454 / 750
points

Cette réponse vous a-t-elle aidé ?

Non (0)

Oui (0)

0% des internautes ont trouvé cette réponse utile

Autres réponses

Patrice
Patrice

Patrice

User level
Niveau
1
133 / 750
points

You have a data plan with FIZZ? It's required for MMS. Otherwise i don't know anything else to try.

John
John

John

User level
Niveau
0
93 / 100
points

Sorry... Plan 8GB + Unlimited Canada + Unlimited Text + no voicemail <=== this better not have cause it.
.
Can anyone else receive MMS?

Eric
Eric

Eric

User level
Niveau
1
286 / 750
points

Go to Settings, Connections, Data usage and put Data saver to Off.
For me, having it On was preventing me from receiving MMS.

Jana
Jana

Jana

User level
Niveau
0
11 / 100
points

Same problem here on Pixel 2xl everything works incl data but MMS can't send or receive Frustrating
Looking for ideas.
Even did network reset on the phone and it did not help

PLEASE HELP ME

Yves
Yves

Yves

User level
Niveau
0
11 / 100
points

I was struggling with this issue on my Pixel 2XL (pie) tonight. Here how I resolved it:

1 - Make sure the APN settings are all correct:
https://fizz.ca/fr/faq/quels-sont-les-parametres-reseau-d...

2 - I had Private DNS set to Private dns: dns.google
Reset this to Automatic and reboot. I believe this is what did it for me.

3 - Clear data and cache for the Carrier Services.

4 - Clear data and cache for the messager app.

Reboot and good luck.